Tuesday, August 5, 2008

XP Embedded: Upgrading Components in Target Designer

So you've been buiding XPe images under SP1 with no problem and made a choice to upgrade to SP2 w/ Feature Pack 2007. Some may have noticed that when the device PMQ is added to the build, an error is now seen as follows "Error 1120: Configuration needs to be upgraded. Service pack level mismatch between current configuration and some components". You will also notice that your PMQ does not show settings options.
To correct this, you need to upgrade the whole configuration. Right Click on *Components* and click upgrade. This should upgrade the whole configuration.

1 comment:

poona said...

Great thoughts you got there, believe I may possibly try just some of it throughout my daily life.


Embedded Software Development